# NerisBot Lab

First, let's see the available indexes.

```splunk-spl
| eventcount summarize=false index=* 
| table index
```

<figure><img src="/files/iBnY4VeAtQ1jfxmWW3nZ" alt=""><figcaption></figcaption></figure>

\#OR&#x20;

From Settings -> Indexes.

<figure><img src="/files/SF1QxjmyXajmNOoiSYhI" alt=""><figcaption></figcaption></figure>

Next, let's see the sourcetypes that we have.

```splunk-spl
| metadata type=sourcetypes
```

<figure><img src="/files/nSfUFqVaVr7gmzkC8gR5" alt=""><figcaption></figcaption></figure>

Q1) Can you identify the IP address from which the initial unauthorized access originated?

```splunk-spl
index=* sourcetype=suricata
| stats values(dest_ip) values(http.hostname) values(http.url) by src_ip
```

<figure><img src="/files/TIGaHBMX1ViOmYpNyOSI" alt=""><figcaption></figcaption></figure>

Answer:  195.88.191.59

Q2) What is the domain name of the attacker server?

<figure><img src="/files/YszzklYRYHXy9aZVKn6F" alt=""><figcaption></figcaption></figure>

Answer:  nocomcom.com

Q3) What is the IP address of the system that was targeted in this breach?

<figure><img src="/files/UU5KyKlc4BB3migjKXzL" alt=""><figcaption></figcaption></figure>

Answer:  147.32.84.165

Q4) Identify all the unique files downloaded to the compromised host. How many of these files could potentially be malicious?

<figure><img src="/files/lXqEpOEKZoK44MAFpZg9" alt=""><figcaption></figcaption></figure>

Answer: 5 &#x20;

Q5) What is the sha256 hash of the malicious file disguised as a txt file?

```splunk-spl
index=* sourcetype=zeek:files tx_hosts="195.88.191.59" 
| join left=L right=R where L.seen_bytes=R.bytes
    [search index=* sourcetype=suricata src_ip=147.32.84.165 dest_ip=195.88.191.59 url=* ]
| table L.md5, L.sha1, R.url
```

<figure><img src="/files/sRN8T3kKINszt84ygkTN" alt=""><figcaption></figcaption></figure>

Let's search by the sha1 on Virustotal to get the sha256.

<figure><img src="/files/muIYsonJlatYnf07bWor" alt=""><figcaption></figcaption></figure>

Answer:  6fbc4d506f4d4e0a64ca09fd826408d3103c1a258c370553583a07a4cb9a6530


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://faresbltagy.gitbook.io/footprintinglabs/cyberdefenders/nerisbot-lab.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
